PDA

View Full Version : Problems with my mower


TnT Outdoor ervices
09-10-2009, 09:44 PM
I have a 2006 52" wright sentar sport with a 19hp kaw 1245hrs. I just changed the oil and I have noticed that around the valve cover oil is leaking out. This is a strong running machine with no knocks. It has had the oil changed every 50hrs and I keep a close eye on the oil every chance I get. It seems to not be using any oil except for the leaking around the valve. Now when I go to engage the clutch it seems to have a hard time turning the pto over. It also seems that the oil dip stick seems really hot as well. Any words of wisdom? What should I do? Wait fix the leak and wait till the motor blows, sell the machine or what. Thanks

Steve
09-11-2009, 11:39 AM
Can you post a picture of the problem area?

SuperiorPower
09-11-2009, 09:55 PM
Did the power loss come on very quickly?

Or gradually?

How bad is the oil loss, meaning is it noticeable on the dipstick?

Could you also please provide me with the model #?

With this info I will try to help you out :)

TnT Outdoor ervices
10-26-2009, 10:42 PM
Thanks for the help guys! I figured it out myself. There are 4 bolts on top and in front ot the motor by the crank that came loose. All I did was bring the bolts tight and the leak stopped. I asked a mechanic at the local mower shop and he said someone else that day had the same problem on the 19 hp kaw. He had never seen this before!

Steve
10-27-2009, 05:22 AM
Maybe they just vibrated loose? Who knows, maybe you should be checking all the bolts now every once in a while.

It reminds me of a friend who used to ride this Harley that would rattle itself apart. After every ride, he had to go through different parts of the bike and retighten them.