PDA

View Full Version : walker mower loosing suction


landonkade
02-28-2008, 05:58 PM
i have a 42in 20hp walker, bought it brand new, as of now its 5 months old. I have been mowing with it for a while. Which i have noticed when i bag grass and leaves at 2.5(mowing level) that i either have to go over the same path 2 times for it to pick up good or lower the deck, which when i lower the deck it scraps the grass.

I would figure if the cutting height is at 2.5 or higher it should pick up very good.

I went to my dealer and they told me that air is getting under it, cause the grass isnt growing much. I think he was telling me a bunch of bull. Cause i have seen yards clean as a whisle when the grass isnt growing when bagged.

At times, if there is a bunch of leaves, it will only pick up half of them.

When i bag a yard i want it to be clean, not leaves and all still in the yard

Any idea what could be wrong.......
**********
i also have a 60in 23hp exmark with a triton deck, when i mulch with it, it does a half but job also, it leaves trails of grass and leaves from the right side of the deck once mowed, i have the deck encloded so the grass cant be thrown out, it is supposed to mulch everything and lay it back down..

any idea y its not mulching correctly

landonkade
02-28-2008, 09:34 PM
Quote[/b] (landonkade @ Feb. 28 2008,5:58)]i have a 42in 20hp walker, bought it brand new, as of now its 5 months old. I have been mowing with it for a while. Which i have noticed when i bag grass and leaves at 2.5(mowing level) that i either have to go over the same path 2 times for it to pick up good or lower the deck, which when i lower the deck it scraps the grass.

I would figure if the cutting height is at 2.5 or higher it should pick up very good.

I went to my dealer and they told me that air is getting under it, cause the grass isnt growing much. I think he was telling me a bunch of bull. Cause i have seen yards clean as a whisle when the grass isnt growing when bagged.

At times, if there is a bunch of leaves, it will only pick up half of them.

When i bag a yard i want it to be clean, not leaves and all still in the yard

Any idea what could be wrong.......
**********
i also have a 60in 23hp exmark with a triton deck, when i mulch with it, it does a half but job also, it leaves trails of grass and leaves from the right side of the deck once mowed, i have the deck encloded so the grass cant be thrown out, it is supposed to mulch everything and lay it back down..

any idea y its not mulching correctly
wow, here we go again, all these views but no answers.

come on guys

Badboyztr
02-29-2008, 12:45 AM
I have a few questions that might help tell what the problem is... one does it work at any height. two did it start suddenly or did it always do this.

Robert Waters
http://www.badboyztr.com

landonkade
02-29-2008, 02:10 PM
Quote[/b] (Badboyztr @ Feb. 29 2008,12:45)]I have a few questions that might help tell what the problem is... one does it work at any height. *two did it start suddenly or did it always do this.

Robert Waters
http://www.badboyztr.com
the walker works at any height, but barly picks up anything. I made a pass on it this morning at my dads before i was going to take it out. His yard is full of leaves. And it barly did anything, so i put it up.

i noticed this not to long ago. It picked up real good when i first bought it

in order for me to get a good suction in a yard i have to put it on 1 1/2 -2, which is bad for the grass,lol

also its been a while since i changed the blades on the walker, i had read somewhere that dull blades could make it lose suction

musician/lawnman
02-29-2008, 10:38 PM
1st check to see if the deck is clogged up, Remove any built up grass clumps, Most machines will do a lousy job if the deck is full of crud. & yes check your blades.... If they are worn & the fin at the back of the blade is gone it will cause suction loss. Change the blades & make sure your deck & bagging system is clear. If your blades suck, your deck won't suck.... then your job sucks. http://www.gophergraphics.com/forum/iB_html/non-cgi/emoticons/biggrin.gif

landonkade
03-01-2008, 12:09 AM
Quote[/b] (musician/lawnman @ Feb. 29 2008,10:38)]1st check to see if the deck is clogged up, *Remove any built up grass clumps, *Most machines will do a lousy job if the deck is full of crud. *& yes check your blades.... *If they are worn & the fin at the back of the blade is gone it will cause suction loss. *Change the blades & make sure your deck & bagging system is clear. * If your blades suck, your deck won't suck.... then your job sucks. * *http://www.gophergraphics.com/forum/iB_html/non-cgi/emoticons/biggrin.gif
k, thanks for the info, i have checked the shout and all, all that is clear, must be the blades, off to the store to get some new ones.