PDA

View Full Version : Snow Removal And Flat Rate Billing question


Steve
12-20-2005, 03:42 PM
QuestionOk, lets say then for example that the snow removal was performed on 12/16 and there is a flat monthly rate for lawn care that is generated as well. I generate the invoice on the 16th, but I decided to choose the generate day of the 17th instead to avoid the problem that I stated earlier. Now, what happens if I end up performing a service on the 17th though, can I still generate it on the next invoice without any problems, even though the last invoice was generated on that date? I know that it might sound confusing. But do you understand what I am talking about? I mean, will I have any problems if I generate an invoice for a date, but then perform a service on that date for the next months invoice?

Answer When you generate invoices you specify a line item date range and it will include all line items within that date range. So if the work was done within that date range it will be included on that invoice.

Steve
12-20-2005, 03:46 PM
QuestionI have two quick questions. It seems when I generate my invoices, any customer that is setup on a flat rate
plan, if I performed a service for them during that same day of invoicing, it will not allow the service to be generated. Sounds kind of confusing, but do you understand? For example, if I performed a snow remvoval on 12/18. And the 18th is just by chance the same day that I do my billing (generate), and if the
customer is setup on a auto billing flat rate plan for lawn care of $100 per month, it will not allow that snow removal service to generate.

The other question, lets say that a customer hasn't paid their invoice, but you want to generate another invoice with the preivous total and late fee is this possible? I mean, I still want to hang onto the old invoice as record of the due date, and I am afraid that if I just change the due date on the invoice that is due, it won't be proper.

Answer When you generate your invoice to include all jobs up to the 18th. Gopher will include your auto billing items and any other jobs in the completed jobs tab that have a date of completion up to and including the 18th.

If you are stuck please let us know, but what you want to do should work.

tiedeman
12-21-2005, 11:53 AM
but when I did it, I had two customers in particular that did not generate the service for that day, only the flat monthly rate

Steve
12-21-2005, 01:22 PM
Hi tiedeman,

Are you generating for specific customer categories? Is it possible those customers aren't in the category?

tiedeman
12-21-2005, 01:40 PM
This is what exactly happened:

The customer is on a auto billing flat monthly rate for lawn maintenance. I also do their snow removal. All of the snow removal services performed NOT on the generated day was generated properly in the invoice, but snow removal that was performed on the generated day did not generate. Only the auto billing was generated.

Instead, the service that was not generated into the invoice was left in the "completed jobs" area still. Almost as if I didn't generate them, when in fact I did, because other customers that were not setup on the auto billing feature, but services that were performed at that same date, did generate into an invoice.

Steve
12-21-2005, 01:59 PM
Ok first off, to correct this, can you ungenerate the invoice for those specif customers and then regenerate for those specific customers so their invoices are correct?

We should try a test with 2 customers.
- Create two new test customers and set up an auto billing item for each.
- Then do a snow plow service for one customer.
- Then generate for only those two customers the same way you have for the others.

This will help us figure out if it was a one time thing that got messed up somehow and won't be repeated or if there is a further problem. It will be a controlled experiment.

tiedeman
12-21-2005, 04:52 PM
I will try it out. How I fixed the problem before was I had to go back into the already generated invoices and enter the information in there.

I will let you know about my test run here in a while though

tiedeman
12-22-2005, 12:38 AM
well, I test it again for one test customer. I setup an auto billing for that customer, and then did a service performed in the Matrix (just like I have been doing lately with customers) I generated only that customer and it came out fine. No problems at all

I will keep you posted though if it happens again when my next generating of invoices occur.

Steve
12-22-2005, 01:46 PM
Ok.

It's tough to find an answer to a problem if it isn't recreatable.

So we will see what happens with it.

tiedeman
12-22-2005, 01:53 PM
thanks again for the support. *I appreciate it greatly!

http://www.gophergraphics.com/forum/iB_html/non-cgi/emoticons/biggrin.gif