PDA

View Full Version : New ZTR battery not charging


w0283767
09-16-2012, 09:17 PM
I have only 8 hours on my brand new Ferris ZTR and today it wouldn't start. I noticed it sounded like it was having a hard time turning over when starting and after turning it on and off over the course of a few yards it got progressively worse until it wouldn't start at all. I jumped it off with my truck and it ran fine. Let it run for about 20 minutes and battery held no charge.Is there anything that I could have done to drain battery? I am new to using these machines but I take the key out when i am not on the machine always and don't know of anything that would drain the battery. I'm taking to the dealer tomorrow if I can't get this figured out. Very frustrating considering how much those machines are to have a breakdown that early.

shadrach
09-16-2012, 09:39 PM
Check fuses.

bruces
09-16-2012, 10:46 PM
it could be any number of things ,a loose connection ,bad battery ,fuse ,alternator ,to name a few .The dealer should have you back running in no time .

Steve
09-17-2012, 10:55 AM
Are there any updates on this situation?

w0283767
09-17-2012, 12:49 PM
Delete is closed Sunday and Monday. I'm going to check fuses and see if I can fix this afternoon. Thanks for the insight. Will let you know what happens.

w0283767
09-24-2012, 03:02 PM
Voltage regulator went out. Dealer replaced at no charge and I am back up and running. Thanks guys.

SECTLANDSCAPING
09-24-2012, 03:05 PM
I have the same issue with one of my ztrs. Gonna check the voltage regulator and fuses when I get a chance.

Steve
09-25-2012, 04:02 AM
When you can't start it and check the voltage output at the battery, what's the best way to see if the voltage regulator is bad when it won't start?