PDA

View Full Version : "Reel Easy" seems to be a real pain in the ***...


WeekendWarriorLawn
06-07-2012, 02:02 PM
Am I the only person who has trouble with the so called reel-easy bump feed system on ryobi whackers?


The scene: my line breaks or wears down too short. I bump the head into the turf a few times and throttle the speed up.


The outcome: nothing happens!

Am i doing something wrong or what? Of course youtube videos make it look so flawlessly easy, but so far I have to keep taking the head apart and restringing the damned f'n thing which makes me look like an a$$.


In MY case, it definitively does NOT continuously feed!!

wat5150
06-07-2012, 02:59 PM
As long as it is wound right the bump head should feed line. Keep in mind that a Ryobi is at best an ok homeowners weed whacker. Ive owned a few of them. They really arent built for the pounding a commercial weed whacker takes. It sucks to spend the money but its best to get a good one at first. Trust me I am dealing with a junk 1 year old trimmer because I didnt want to spend the money on a good one. By the way its a ryobi. Anyway just make sure your spool is wound good and that your line isnt getting jammed.

SECTLANDSCAPING
06-07-2012, 10:22 PM
Could be a bad spring.

Not only are the commercial brands more durable the trimmer heads are built way better. I would never put a universal head on my redmax or stihls.

wandfsmall
06-08-2012, 07:27 AM
we have enough problems with the redmax easy feed heads on commercial users, I would hate to see how bad a ryobi unit holds up. If I were you I would buy a standard bump head.