PDA

View Full Version : Briggs 625 series - almost running ?


knosaj
02-13-2012, 09:33 PM
finally got everything back together. the mower sat out in the rain for a few days thanks to someone. only thing missing is choke / throttle lever. ill have to rig up something. the part is like 50 bucks. like a third of what i paid for the mower!

anyway

did everything i know how. i think its not getting enough fuel.

when i prime the bulb it starts for a second, if i am fast enough i pull the choke or throttle lever (not sure which direction, but when i have it wide open i can feel it pulling back pretty hard.) and while i am pulling the lever, i am pushing the bulb. doing both at the same time i can get this mower GOING! if i either let go of the lever, suction or soemthing pulls it back, or stop repeatedly pressing the buld, the engine dies in about 2 seconds.

i kept it running for about 3 minutes nearly topped out, just to see if it would catch. it didnt.

any ideas? id rather not take it to the shop for such a cheap mower.

thanks.

willshome
02-13-2012, 09:44 PM
can you post a pic or two

knosaj
02-13-2012, 10:43 PM
here is.

the spring is part of the throttle or choke. not sure which it is. there are no marks on the motor or cowling any place.

after its running i hold the bar (that the spring is attached to) forward it stays running. something is pulling it back pretty hard. i guess that is the suction from the fuel system. i guess.

the bulb is in the front of the mower.

the mower is filthy now, but looks new when clean

bruces
02-13-2012, 10:45 PM
if it runs when you prime it,it probably has a dirty carb ,but its hard to tell from your post as I cant understand it as written .

Steve
02-14-2012, 05:33 PM
something is pulling it back pretty hard. i guess that is the suction from the fuel system. i guess.

Is it the governor that is pulling it back?

bruces
02-14-2012, 06:27 PM
after re-reading your posts ,is it possible its the safety shut down your talking about ?

knosaj
02-14-2012, 08:29 PM
i wish i knew exatly. i do know that the wire/bar thing that is pulling back is part of the same assembly that the throttle lever is part of. when the engine is off, the wire/bar thing is completely loose.


i am typically able to figure almost anytihng out.

i guess small engine repair will be next on the list.

wandfsmall
02-15-2012, 09:17 AM
here is.

the spring is part of the throttle or choke. not sure which it is. there are no marks on the motor or cowling any place.

after its running i hold the bar (that the spring is attached to) forward it stays running. something is pulling it back pretty hard. i guess that is the suction from the fuel system. i guess.

the bulb is in the front of the mower.

the mower is filthy now, but looks new when clean

Ok, the spring is your governor, it is an air vain system from the look of it so that is what is pulling back on it trying to slow the engine down. Your likely problem is your carb needs cleaning with your problem though. if you choke the system it still pulls enough fuel to run.