PDA

View Full Version : C Cadet blades disengage


mhatkins
07-10-2010, 02:26 PM
My 33" walk behind has developed a problem of the blades disengaging in medium grass. I bought the unit used a few months ago. It's a 2009 year model, but didn't come with the owners manual. Having a problem finding info on these mowers with that problem. Other than that, I havent had minutes problem out of it. Any ideas of what may be the problem? :confused:

NewLeafca
07-10-2010, 09:00 PM
It could be several things. Do you know what model it is? Is it a manual lever clutch or a electronic clutch?

majoe7
07-11-2010, 12:27 PM
Is it disengaging or bogging down when you are cutting medium grass compared to short grass? Do you have a mulching kit on it or just side discharge? If you are cutting in medium grass and it starts to disengage can you push down on the levers/handles to lift the front end up off the ground and keep it engaged? If you just bought it take it back and have them look at it to find the problem. I assume that you have at least a 90 day warranty on it?

One who can help is Eli (Superior Power Equipment).

Good luck and keep us posted.

John

mhatkins
07-11-2010, 12:51 PM
I bought it used off craigslist. I can push on the handles and the blades will keep going. It only has a side discharge. Not exactly sure of the model. It the 33" Timesaver wb mower.

majoe7
07-11-2010, 03:24 PM
Will it stay engaged and cut on normal length grass, say 3-4 inches? Can you raise the height of the deck? Is there any build up of grass underneath the deck? Are the belts in good shape or worn?